You appear to be browsing this site using Internet Explorer 6. This browser is now out of date.
For safer, more reliable browsing it is recommended that you upgrade your browser to one of these browsers:

Firefox / Safari / Opera / Chrome / Internet Explorer 8+

ODMS for administrators, Olympus, Transcription Software

ODMS FOR ADMINISTRATORS

Admin Tools for ODMS
  • User and group management
  • Central workflow administration
  • Easy & silent software deployment

Specifications

Operating Systems & Requirements

  • Supported Operating Systems:

  • Microsoft® Windows Vista®

    Ultimate / Enterprise / Business SP2 (x86/x64)

  • Microsoft® Windows® 7

    Ultimate / Enterprise / Professional SP1 (x86/x64)

  • Microsoft® Windows® 8 / 8.1 Update

    Enterprise / Pro / Windows 8 / 8.1 (x86/x64)

  • Microsoft® Windows® 10

    Home / Pro / Enterprise (x86/x64)

  • Microsoft® Windows Server®

    2003 SP2 (x86/x64)

  • 2003 R2 SP2 (x86/x64)

  • 2008 SP2 (x86/x64)

  • 2008 R2 SP1 (x86/x64)

  • 2012 (x64)

  • 2012 R2 (x64)

  • Minimum System Requirements:

  • Microsoft® Windows Vista®

    1GHz CPU, 1 GB RAM

  • Microsoft® Windows® 7

    1GHz CPU, 1GB RAM (x86); 2 GB (x64)

  • Microsoft® Windows® 8 / 8.1

    2GHz CPU, 1GB RAM (x86); 2 GB (x64)

  • Microsoft® Windows® 10

    2GHz CPU, 2GB RAM

  • Microsoft® Windows Server® 2003

    1GHz CPU, 256 MB

  • Microsoft® Windows Server® 2008

    2GHz CPU, 2 GB

  • Microsoft® Windows Server® 2012

    2GHz CPU, 2 GB

  • .NET Framework

    4.0

  • Free HDD Space

    2GB

  • Dictation network requirements:

  • Clients with ODMS Transcription Module or Dictation Module

  • Multi User License (MUL)

  • Note:

  • In Windows Server 2003, TS CAL license is required to use ODMS on Terminal Service. In Windows Server 2008 / 2012, RDS CAL license is required to use ODMS on Remote Desktop Service or RemoteApp. For using VMware View, requires separate VMware View user license. In case of using ODMS together with Dragon / Dragon NaturallySpeaking by Nuance the system requirements of the particular software application must also be taken into account.

Supported Virtual Environment Platforms

  • Remote Desktop Service (Windows Terminal Service)

    Microsoft® Windows Server® 2003 / 2008 / 2012 R2

  • RemoteApp

    Microsoft® Windows Server® 2008 / 2012 R2

  • Citrix XenApp

    XenApp 5 / 6 / 6.5 / 7.6

  • Citrix Desktop

    XenDesktop 4 / 5 / 5.6 / 7 / 7.6

  • Citrix Client applications

    Citrix Online Plug‑in 12.0.0 or later

  • Citrix Receiver 3.0 or later

  • Vmware View

    VMware View 4.5 / 5 (VMware View Clients 5.0 or later is required)

  • VMware Horizon View 5.2 / 5.3 / 6 (VMware View Clients 5.2 or later is required)